Cómo instalar vyOS RouterOS con KVM

vyOS es un cortafuegos gratuito y de código abierto basado en Debian Linux. vyOS puede desplegarse tanto en la virtualización como en la nube, es compatible con KVM, VMWare, Proxmox, Hyper-V, Nutanic, Xen, etc. vyOS puede utilizarse como plataforma de enrutamiento y cortafuegos, proporciona enrutamiento de red basado en software, cortafuegos, VPN y seguridad.

En este tutorial, te mostraremos cómo instalar y configurar el router vyOS en una máquina virtual KVM.

Requisitos previos

  • Un sistema Linux con virtualización KVM
  • Archivo ISO de vyOS
  • Una máquina cliente Linux

Crear una máquina virtual vyOS

Para crear una nueva máquina virtual para el vyOS, puedes utilizar el modo de línea de comandos desde el terminal o utilizar la aplicación GUI mediante el virt-manager.

En este tutorial, crearás una máquina virtual vyOS utilizando la aplicación GUI virt-manager.

Abre la aplicación virt-manager y crea una nueva máquina virtual.

crear nueva vm

Selecciona la opción de instalar desde la imagen ISO del medio y haz clic en Adelante.

fuente iso

Selecciona el archivo ISO del vyOS y elige el sistema operativo para instalar a Debian 11 y haz clic en Adelante.

elegir iso y tipo de sistema

Introduce el tamaño de la memoria del vyOS y de las CPUs y haz clic en Adelante.

configurar ram y cpus

Introduce el tamaño del disco para la instalación del vyOS y haz clic en Adelante.

configurar el tamaño del disco

Cambia el nombre a vyos y para la selección de Red, selecciona NAT por defecto y haz clic en Finalizar.

cambiar el nombre y configurar la red

Ya has creado la máquina virtual para vyOS.

Instalar el router vyOS

Tras crear la máquina virtual para vyOS, ahora estás preparado para instalar vyOS en tu virtualización KVM.

Inicia la máquina virtual de vyOS y cuando esté en marcha, verás la siguiente pantalla.

Selecciona Live (amd64-vyos) y pulsa ENTER.

vyos bota

Cuando esté en marcha, inicia sesión con el usuario por defecto vyos y una contraseña en blanco.

acceso a vyos por defecto

Para instalar vyOS en la máquina virtual, introduce la línea de comandos que aparece a continuación.

install image
  • Pulsa ENTER para confirmar y continuar la instalación.
  • Para la partición, pulsa ENTER para utilizar el modo automático.
  • Ahora vuelve a pulsar ENTER para confirmar la instalación de vyOS en tu disco.

instalar vyos

Ahora vas a configurar la partición y la contraseña de vyOS.

  • Introduce el para confirmar y destruir la partición por defecto.
  • Para el tamaño de la partición raíz, déjalo por defecto y pulsa ENTER.
  • Deja el nombre de la imagen del vyOS por defecto y pulsa ENTER para continuar.
  • Ahora pulsa ENTER de nuevo para copiar la configuración por defecto config. boot a tu instalación.
  • Introduce una nueva contraseña para el usuario vyos y repite la contraseña. Por favor, utiliza una contraseña fuerte para la contraseña del usuario vyos.

instalar vyos

Para completar la instalación de vyOS, vas a instalar GRUB.

El instalador de vyOS detectará automáticamente tu disco para la instalación de GRUB. En este ejemplo, el disco es /dev/vda, ahora pulsa ENTER para confirmar la instalación de GRUB.

vyos install grub

Una vez finalizada la instalación de GRUB, ejecuta el comando reboot para reiniciar tu máquina virtual vyOS.

A continuación se muestra el GRUB de la máquina virtual vyOS.

vyos install grub

Ahora inicia sesión con el usuario por defecto vyos e introduce tu contraseña. A continuación habrás instalado con éxito vyOS en la virtualización KVM.

acceder a vyos

Creación de una interfaz de red adicional

En este ejemplo, vas a configurar las interfaces de red para el vyOS.

La configuración actual del vyOS está utilizando la red por defecto en la virtualización KVM de tipo NAT.

Ahora crearás una nueva red virtual en la virtualización KVM y adjuntarás la red virtual a la máquina virtual del vyOS.

En el virt-manager de configuración de red, haz clic en el botón + para añadir una nueva red.

Introduce el nombre y la configuración detallada de la red como se indica a continuación.

  • Nombre: interna
  • Modo: Aislada
  • Red IPv4: 192.168.50.0/24
  • Inicio – Fin de DHCPv4: 192 .168.50.128 – 192.168.50.254

Haz clic en Finalizar para confirmar.

Añadir nueva interfaz KVM

Ahora apaga tu máquina virtual vyOS y abre la configuración de detalles de la máquina virtual vyOS, haz clic en el botón Añadir hardware para añadir una nueva interfaz de red.

Selecciona«Red» y el«Origen de la red» a«interna: Red aislada«. Ahora haz clic en Finalizar.

Añade una segunda interfaz de red

Ahora vuelve a arrancar la máquina virtual vyOS para empezar a configurar la red vyOS.

Configuración de vyOS

Ahora has adjuntado una nueva interfaz de red a la máquina virtual vyOS. A continuación, empezarás a configurar el router vyOS.

Accede a tu router vyOS utilizando el usuario vyos y tu contraseña segura.

Ahora ejecuta el comando configure para iniciar el modo de configuración en vyOS.

configure

Comprueba las interfaces de red disponibles en vyOS utilizando el siguiente comando.

ip a

Como puedes ver en la captura de pantalla de abajo, en este ejemplo tenemos dos interfaces de red eth0 y eth1.

Además, te darás cuenta de que cuando entres en el modo de edición, verás el [edit] encima del nombre de host de vyOS. También, notarás la diferencia al entrar en el modo de edición, el shell se cambia a [email protected]#, en lugar de [email protected]:~$.

entra en el modo de edición vyos y comprueba la ip

Define la WAN y la LAN

Ahora has entrado en el modo de edición en vyOS. Vamos a empezar a configurar la dirección IP en vyOS.

En primer lugar, tendrás que decidir qué interfaces se utilizarán como EXTERNO/WAN y qué interfaz se utilizará como INTERNO/LAN.

En este ejemplo, la interfaz EXTERNA/WAN será eth0, y la INTERNA/LAN será la interfaz eth1.

Configurar eth0 WAN

Ahora ejecuta el siguiente comando para configurar la interfaz WAN/EXTERNA eth0.

En este ejemplo, el eth0 obtendrá una dirección IP 192.168.100.15. Además, configurarás el enrutamiento estático para eth0 hacia el host KVM en la dirección IP 192 .168.100.1.

Después de cada cambio, ejecuta el comando commit para aplicar la nueva configuración, y luego ejecuta save para guardar los nuevos cambios.

set interfaces ethernet eth0 address 192.168.100.15/24
set protocols static route 0.0.0.0/0 next-hop 192.168.100.1
commit
save

configurar la WAN y configurar el enrutamiento por defecto

Configurar la LAN eth1

Ahora vas a configurar la interfaz eth1 para INTERNAL/LAN. Esta interfaz será utilizada por las máquinas virtuales bajo el router vyOS.

Ejecuta el siguiente comando para configurar la dirección IP de eth1 a 192.168.50.10 y añade la descripción de la interfaz eth1 a LAN. Ahora confirma la configuración y guarda los cambios.

set interfaces ethernet eth1 address 192.168.50.10/24
set interfaces ethernet eth1 description LAN
commit
save

configurar la interfaz LAN

A continuación, ejecuta el siguiente comando para crear una nueva regla NAT para la dirección IP 192.168.50.0/24 de la interfaz LAN eth1.

Crearás un nuevo NAT saliente para la dirección IP 192 . 168.50.0/24 de eth1 hacia la interfaz EXTERNA/WAN eth0. El tipo de NAT aquí es de enmascaramiento, luego confirma los nuevos cambios y guarda la nueva configuración.

set nat source rule 100 source address 192.168.50.0/24
set nat source rule 100 outbound-interface eth0
set nat source rule 100 translation address masquerade
commit
save

configuración nat vyos

Configurar el reenvío de DNS

Ahora vas a configurar el reenvío de DNS en vyOS.

Ejecuta el siguiente comando para configurar el servicio de reenvío de DNS. En este ejemplo, el servicio DNS se ejecutará en la dirección IP de la LAN 192.168.50.10, y permitirá el acceso desde la red interna eth1. A continuación, confirma la configuración y guarda los cambios.

set service dns forwarding listen-address 192.168.50.10
set service dns forwarding allow-from 192.168.50.0/24
set service dns forwarding cache-size 0
commit
save

configurar el reenvío de dns

A continuación, define el reenviador para el servicio DNS. En este ejemplo, utilizaremos el DNS público de Cloudflare y Google como reenviador.

Ejecuta el siguiente comando para configurar el reenvío de DNS a Cloudflare y Google DNS. A continuación, confirma los cambios y guarda la configuración.

set service dns forwarding name-server 1.1.1.1
set service dns forwarding name-server 8.8.8.8
commit
save

configurar reenviadores dns

Ahora ejecuta el siguiente comando para cambiar el DNS de vyOS al servidor DNS local 192.168.50.10. A continuación, confirma los cambios y guarda la configuración.

set system name-server 192.168.50.10
commit
save

configurar dns local vyos

Prueba de la configuración de la red

Ahora has completado la configuración de red en vyOS, que incluye la dirección IP de la WAN, la dirección IP de la LAN y el servicio de reenvío de DNS.

Para verificar la configuración de red, ejecuta el siguiente comando para hacer un ping a Internet.

run ping youtube.com count 3

Si tu configuración de red es correcta, podrás hacer ping a internet fuera de la red.

prueba de ping desde el router vyos

A continuación, ejecuta el siguiente comando para comprobar las interfaces de red detalladas.

show interfaces

Ahora verás la dirección IP detallada de las interfaces eh0 y eth1.

mostrar dirección ip

Para comprobar las reglas NAT, ejecuta el siguiente comando.

show nat source rules

Ahora obtendrás la siguiente salida. La regla nat número 100 escribe NAT de salida a la interfaz eth0 y el origen es la red eth1.

mostrar nat

A continuación, ejecuta el siguiente comando para comprobar el servicio de reenvío de DNS.

configure
show service dns

Deberías obtener una salida como la siguiente El servicio de reenvío de DNS se está ejecutando en la interfaz eth1 192.168.50.10 y utiliza los servidores DNS públicos de Cloudflare y Google como reenviadores.

mostrar configuración dnse

Configurar el sistema Ubuntu 20.04 del cliente

En el lado del cliente, tendrás que configurar una dirección IP estática con la puerta de enlace por defecto a la dirección Ip del vyOS 192.168.50.10. En este ejemplo, el cliente es el sistema Ubuntu 20.04.

Edita la configuración de red /etc/netplan/01-netcfg.yaml.

sudo nano /etc/netplan/01-netcfg.yaml

Copia la siguiente configuración para establecer la dirección IP estática para el sistema ubuntu.

configurar dirección ip estática netplan

Guarda y cierra el archivo cuando hayas terminado.

Ahora aplica los nuevos cambios utilizando el comando netplan que aparece a continuación.

sudo netplan apply

Después, verifica la dirección IP en el sistema Ubuntu y verifica la tabla de enrutamiento de la red Ubuntu.

ip a
route -n

A continuación puedes ver que el sistema ubuntu tiene la dirección IP estática correcta 192.168.50.100 con la puerta de enlace por defecto de la dirección IP del vyOS 192.168.50.10.

comprobar la dirección ip y el enrutamiento ubuntu

Ahora ejecuta el comando ping de abajo para verificar la conexión con el router vyOS.

ping 192.168.50.10 -c3

A continuación puedes ver que el cliente de Ubuntu puede conectarse al router vyOS.

ping al router vyos

A continuación, ejecuta el siguiente comando para comprobar la conexión a Internet.

ping 1.1.1.1 -c3
ping google.com -c3

A continuación puedes ver que el sistema Ubuntu puede conectarse a Internet a través del router vyOS.

ping a internet

Conclusión

¡Enhorabuena! Ya has instalado y configurado el router vyOS en la virtualización KVM. Además, has aprendido a añadir un cliente y a configurar la dirección IP estática en el lado del cliente para conectarse al router vyOS.

También te podría gustar...